aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 349fb4c37..b230e2b66 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1514,6 +1514,7 @@ C_TESTS = \
test/test_pcm \
test/test_protocol \
test/test_queue_priority \
+ test/TestFs \
test/TestIcu
if ENABLE_CURL
@@ -2164,6 +2165,14 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+test_TestFs_SOURCES = \
+ test/TestFs.cxx
+test_TestFs_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_TestFs_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_TestFs_LDADD = \
+ $(FS_LIBS) \
+ $(CPPUNIT_LIBS)
+
test_TestIcu_SOURCES = \
test/TestIcu.cxx
test_TestIcu_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0