aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a68d070ed..cbdd2a618 100644
--- a/configure.ac
+++ b/configure.ac
@@ -784,8 +784,7 @@ fi
AM_CONDITIONAL(HAVE_MIKMOD, test x$enable_mod = xyes)
if test x$enable_ffmpeg = xyes; then
- PKG_CHECK_MODULES(FFMPEG, [libavformat libavcodec libavutil],
- AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support]),
+ PKG_CHECK_MODULES(FFMPEG, [libavformat libavcodec libavutil],,
enable_ffmpeg=no)
fi
@@ -808,6 +807,10 @@ if test x$enable_ffmpeg = xyes; then
CPPCFLAGS=$old_CPPFLAGS
fi
+if test x$enable_ffmpeg = xyes; then
+ AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support]),
+fi
+
AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
case $with_zeroconf in