From fa34dd7bd3e0222811010dda6d1b40c4e3b3291b Mon Sep 17 00:00:00 2001
From: Max Kellermann <max@duempel.org>
Date: Tue, 29 Jan 2013 22:40:11 +0100
Subject: test/visit_archive: new debug program

---
 Makefile.am | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

(limited to 'Makefile.am')

diff --git a/Makefile.am b/Makefile.am
index c3b52ebd6..a1e430403 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1038,6 +1038,10 @@ noinst_PROGRAMS = \
 	test/run_normalize \
 	test/software_volume
 
+if ENABLE_ARCHIVE
+noinst_PROGRAMS += test/visit_archive
+endif
+
 if HAVE_ID3TAG
 noinst_PROGRAMS += test/dump_rva2
 endif
@@ -1089,6 +1093,28 @@ test_run_input_SOURCES = test/run_input.cxx \
 	src/uri.c \
 	src/fd_util.c
 
+if ENABLE_ARCHIVE
+
+test_visit_archive_LDADD = \
+	$(INPUT_LIBS) \
+	$(ARCHIVE_LIBS) \
+	libevent.a \
+	libfs.a \
+	$(GLIB_LIBS)
+test_visit_archive_SOURCES = test/visit_archive.cxx \
+	src/IOThread.cxx \
+	src/InputStream.cxx \
+	src/ConfigFile.cxx src/tokenizer.c src/utils.c src/string_util.c \
+	src/Tag.cxx src/TagNames.c src/TagPool.cxx \
+	src/uri.c \
+	src/fd_util.c
+
+if ENABLE_DESPOTIFY
+test_visit_archive_SOURCES += src/DespotifyUtils.cxx
+endif
+
+endif
+
 test_dump_text_file_LDADD = \
 	$(INPUT_LIBS) \
 	$(ARCHIVE_LIBS) \
-- 
cgit v1.2.3