From 18cdbfa70f137b40466700eda11352f126ca810c Mon Sep 17 00:00:00 2001
From: Avuton Olrich <avuton@gmail.com>
Date: Sat, 17 Apr 2010 03:39:56 -0700
Subject: configure.ac: Move libmodplug to Decoder Plugins, add header.

---
 configure.ac | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)

(limited to 'configure.ac')

diff --git a/configure.ac b/configure.ac
index ad2b973be..4456b2a7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -711,15 +711,7 @@ dnl ###
 
 
 
-found_modplug=$HAVE_CXX
-MPD_AUTO_PRE(modplug, [modplug decoder plugin], [No C++ compiler found])
 
-MPD_AUTO_PKG(modplug, MODPLUG, [libmodplug],
-	[modplug decoder plugin], [libmodplug not found])
-AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
-if test x$enable_modplug = xyes; then
-	AC_DEFINE(HAVE_MODPLUG, 1, [Define for modplug support])
-fi
 
 AC_ARG_ENABLE(gme,
 	AS_HELP_STRING([--enable-gme],
@@ -1047,8 +1039,17 @@ fi
 
 AM_CONDITIONAL(ENABLE_MIKMOD_DECODER, test x$enable_mikmod = xyes)
 
+dnl -------------------------------- libmodplug -------------------------------
+found_modplug=$HAVE_CXX
+MPD_AUTO_PRE(modplug, [modplug decoder plugin], [No C++ compiler found])
 
+MPD_AUTO_PKG(modplug, MODPLUG, [libmodplug],
+	[modplug decoder plugin], [libmodplug not found])
 
+if test x$enable_modplug = xyes; then
+	AC_DEFINE(HAVE_MODPLUG, 1, [Define for modplug support])
+fi
+AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
 
 
 
-- 
cgit v1.2.3