From 191e520999c172a5316c3b54c2b32ab7ff32be36 Mon Sep 17 00:00:00 2001
From: Avuton Olrich <avuton@gmail.com>
Date: Fri, 16 Apr 2010 19:58:00 -0700
Subject: configure.ac: Move converter plugins up with other aux plugins.

---
 configure.ac | 39 +++++++++++++++++++++------------------
 1 file changed, 21 insertions(+), 18 deletions(-)

(limited to 'configure.ac')

diff --git a/configure.ac b/configure.ac
index 2c6fca9c3..b79e09ef8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -573,6 +573,27 @@ fi
 
 AM_CONDITIONAL(ENABLE_SQLITE, test x$enable_sqlite = xyes)
 
+dnl ---------------------------------------------------------------------------
+dnl Converter Plugins
+dnl ---------------------------------------------------------------------------
+
+dnl ------------------------------ libsamplerate ------------------------------
+MPD_AUTO_PKG(lsr, SAMPLERATE, [samplerate >= 0.0.15],
+	[libsamplerate resampling], [libsamplerate not found])
+if test x$enable_lsr = xyes; then
+	AC_DEFINE([HAVE_LIBSAMPLERATE], 1,
+		[Define to enable libsamplerate])
+fi
+
+if test x$enable_lsr = xyes; then
+	PKG_CHECK_MODULES([SAMPLERATE_013],
+		[samplerate >= 0.1.3],,
+		[AC_DEFINE([HAVE_LIBSAMPLERATE_NOINT], 1,
+		[libsamplerate doesn't provide src_int_to_float_array() (<0.1.3)])])
+fi
+
+AM_CONDITIONAL(HAVE_LIBSAMPLERATE, test x$enable_lsr = xyes)
+
 dnl ---------------------------------------------------------------------------
 dnl Input Plugins
 dnl ---------------------------------------------------------------------------
@@ -827,25 +848,7 @@ if test x$enable_wavpack = xyes; then
 	AC_DEFINE([HAVE_WAVPACK], 1, [Define to enable WavPack support])
 fi
 
-dnl ---------------------------------------------------------------------------
-dnl Converter Plugins
-dnl ---------------------------------------------------------------------------
 
-MPD_AUTO_PKG(lsr, SAMPLERATE, [samplerate >= 0.0.15],
-	[libsamplerate resampling], [libsamplerate not found])
-if test x$enable_lsr = xyes; then
-	AC_DEFINE([HAVE_LIBSAMPLERATE], 1,
-		[Define to enable libsamplerate])
-fi
-
-if test x$enable_lsr = xyes; then
-	PKG_CHECK_MODULES([SAMPLERATE_013],
-		[samplerate >= 0.1.3],,
-		[AC_DEFINE([HAVE_LIBSAMPLERATE_NOINT], 1,
-		[libsamplerate doesn't provide src_int_to_float_array() (<0.1.3)])])
-fi
-
-AM_CONDITIONAL(HAVE_LIBSAMPLERATE, test x$enable_lsr = xyes)
 
 dnl ---------------------------------------------------------------------------
 dnl Encoders for Streaming Audio Output Plugins
-- 
cgit v1.2.3