From 9d55b16998b6336bfdd6ea0ae3ac31f8685521f6 Mon Sep 17 00:00:00 2001
From: Tony Miller <mcfiredrill@gmail.com>
Date: Sat, 10 Apr 2010 01:05:16 -0700
Subject: Decoder for game music emulation library.

Supports a number of videogame music formats, more info here:
http://www.fly.net/~ant/libs/audio.html

I wrote this plugin for the latest svn, get it here:
http://code.google.com/p/game-music-emu/source/checkout
---
 configure.ac | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

(limited to 'configure.ac')

diff --git a/configure.ac b/configure.ac
index 0c2d694bb..8ae21793a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -527,6 +527,18 @@ if test x$enable_modplug = xyes; then
 	AC_DEFINE(HAVE_MODPLUG, 1, [Define for modplug support])
 fi
 
+AC_ARG_ENABLE(gme,
+	AS_HELP_STRING([--enable-gme],
+		[enable Blargg's game music emulator plugin]),,
+	enable_gme=auto)
+
+MPD_AUTO_PKG(gme, GME, [libgme],
+	[gme decoder plugin], [libgme not found])
+AM_CONDITIONAL(HAVE_GME, test x$enable_gme = xyes)
+if test x$enable_gme = xyes; then
+	AC_DEFINE(HAVE_GME, 1, [Define for gme support])
+fi
+
 AC_ARG_ENABLE(mpc,
 	AS_HELP_STRING([--disable-mpc],
 		[disable musepack (MPC) support (default: enable)]),,
@@ -1547,6 +1559,12 @@ else
 	echo " MODPLUG support ...............disabled"
 fi
 
+if test x$enable_gme = xyes; then
+	echo " GME support ....................enabled"
+else
+	echo " GME support ...................disabled"
+fi
+
 if test x$enable_mad = xyes; then
 	echo " MAD mp3 decoder support .......enabled"
 else
@@ -1633,6 +1651,7 @@ if
 	test x$enable_ffmpeg = xno &&
 	test x$enable_modplug = xno &&
 	test x$enable_sidplay = xno &&
+	test x$enable_gme = xno &&
 	test x$enable_fluidsynth = xno &&
 	test x$enable_wildmidi = xno &&
 	test x$enable_mp4 = xno &&
-- 
cgit v1.2.3