From bdb3129f18cc42dce09984108801937512667209 Mon Sep 17 00:00:00 2001
From: Max Kellermann <max@duempel.org>
Date: Wed, 25 Feb 2009 16:46:07 +0100
Subject: configure.ac: declare AM_CFLAGS

Moved generic compiler options to AM_CFLAGS.  MPD_CFLAGS/MPD_LIBS will
hopefully fade away one day, in favor of more fine-grained variables.
---
 configure.ac | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

(limited to 'configure.ac')

diff --git a/configure.ac b/configure.ac
index ddebb0bdc..653bea29d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,8 @@ dnl
 dnl declare variables
 dnl
 
+AC_SUBST(AM_CFLAGS,"")
+
 AC_SUBST(MPD_LIBS)
 AC_SUBST(MPD_CFLAGS)
 MPD_LIBS=""
@@ -1105,7 +1107,7 @@ AC_ARG_ENABLE(werror,
 	ENABLE_WERROR=no)
 
 if test "x$ENABLE_WERROR" = xyes; then
-	MPD_CFLAGS="$MPD_CFLAGS -Werror -pedantic-errors"
+	AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
 fi
 
 AC_ARG_ENABLE(debug,
@@ -1116,7 +1118,7 @@ AC_ARG_ENABLE(debug,
 
 #if test "x$ENABLE_DEBUG" = xno; then
 	# don't set NDEBUG for now, until MPD is stable
-	#MPD_CFLAGS="$MPD_CFLAGS -DNDEBUG"
+	#AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
 #fi
 
 AC_ARG_ENABLE(gprof,
-- 
cgit v1.2.3