aboutsummaryrefslogtreecommitdiffstats
path: root/dev-util/npm/npm-1.0.105.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2011-11-16 19:00:06 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2011-11-16 19:00:28 +0100
commit93b291cce8fd6ab130ab760ac61f7034834c87cf (patch)
tree656a7cf0ae68adc0a0fe04835f174b814daf13e2 /dev-util/npm/npm-1.0.105.ebuild
parent071bbbc40127afcaec75fc0ae31814344e5aa9c7 (diff)
downloadoverlay-93b291cce8fd6ab130ab760ac61f7034834c87cf.tar.gz
overlay-93b291cce8fd6ab130ab760ac61f7034834c87cf.tar.xz
overlay-93b291cce8fd6ab130ab760ac61f7034834c87cf.zip
dev-util/npm: moved from net-libs
Diffstat (limited to 'dev-util/npm/npm-1.0.105.ebuild')
-rw-r--r--dev-util/npm/npm-1.0.105.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/npm/npm-1.0.105.ebuild b/dev-util/npm/npm-1.0.105.ebuild
new file mode 100644
index 0000000..ef9ff0b
--- /dev/null
+++ b/dev-util/npm/npm-1.0.105.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A package manager for nodejs."
+HOMEPAGE="http://npmjs.org"
+SRC_URI="http://registry.npmjs.org/npm/-/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND} net-libs/nodejs"
+
+S="${WORKDIR}/package"
+
+src_configure() {
+ econf --prefix="${D}usr/" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}usr/" install || die
+
+ # remove doc directories form wrong pathq
+ rm -rf "${D}usr/lib/node_modules/npm/doc/"
+ rm -rf "${D}usr/lib/node_modules/npm/html/"
+
+ dodoc README.md CHANGES AUTHORS || die
+ if use doc ; then
+ # install doc and api html pages
+ dodoc -r html/doc/ || die
+ dodoc -r html/api/ || die
+ fi
+
+ # fix npm paths
+ sed -i "s~${D}usr~@PREFIX@~" "${D}usr/lib/node_modules/npm/npmrc"
+}
+
+pkg_postinst() {
+ #fix npm paths
+ sed -i "s~@PREFIX@~${ROOT}usr/~" "${ROOT}usr/lib/node_modules/npm/npmrc"
+}